Contacts - Unable to perform a Search

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Contacts - Unable to perform a Search

Rudolf Künzli
I upgraded to evolution 3.24.3-1
I am running into a slight problem:

The backend for this address book was unable to parse this query. Error
code 503 when querying: <?xml version="1.0" encoding="UTF-8"?>
<errors xmlns="http://schemas.google.com/g/2005">;;
 <error>
  <domain>GData</domain>
  <code>backendError</code>
  <internalReason>Backend Error</internalReason>
 </error>
</errors>

Any idea what's going wrong here ?

Thanks

--
Rudolf Künzli <[hidden email]>
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Milan Crha
On Tue, 2017-07-18 at 18:44 +0200, Rudolf Künzli wrote:
> Any idea what's going wrong here ?

        Hi,
it sounds similar to this old entry:
https://groups.google.com/forum/#!topic/google-analytics-data-export-api/tGV06V-ZBeY

I guess it's due to doing particular search, which transforms into
something what the Google server cannot handle. Could you share what
you are trying to search for (in some very precise form), please? You
can avoid exposing exact search terms, like contact names, only mention
if it contained any UTF-8 letters, or only plain ASCII letters.

        Thanks and bye,
        Milan
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Rudolf Künzli
On Tue, 2017-07-18 at 19:16 +0200, Milan Crha wrote:

> On Tue, 2017-07-18 at 18:44 +0200, Rudolf Künzli wrote:
> > Any idea what's going wrong here ?
>
> Hi,
> it sounds similar to this old entry:
> https://groups.google.com/forum/#!topic/google-analytics-data-export-
> api/tGV06V-ZBeY
>
> I guess it's due to doing particular search, which transforms into
> something what the Google server cannot handle. Could you share what
> you are trying to search for (in some very precise form), please? You
> can avoid exposing exact search terms, like contact names, only
> mention
> if it contained any UTF-8 letters, or only plain ASCII letters.
>
> Thanks and bye,
> Milan
> _____________________
>
I did a search some minutes before without error message.
I turned back to the mail window.
When I opened the contacts window again I saw the error message.
Now, evolution is up for hours I don't have an error message.
I can't repeat the problem easily...

> __________________________
> evolution-list mailing list
> [hidden email]
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-list
--
Rudolf Künzli <[hidden email]>
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Milan Crha
On Tue, 2017-07-18 at 23:36 +0200, Rudolf Künzli wrote:
> I can't repeat the problem easily...

        Hi,
okay, that's a pita. Could you keep running evolution-addressbook-
factory with EWS debugging on in the background, and when it'll strike
back, then check the log for the backendError message and what preceded
it, please? That would show what evolution-ews passed to the server and
eventually shed a bit of light on the issues.

To do that:
a) close evolution
b) open terminal and run in it:
   $ EWS_DEBUG=2 /usr/libexec/evolution-addressbook-factory -w &>log.txt
   Actual path can differ on your system.
c) run evolution and use it as before

The log contains all the communication between the server and the
client, exposing all the private information down to your contacts, but
the only interesting part is the one with the backendError and what
precedes it. Maybe file a bug report in GNOME bugzilla and we can
follow there. Feel free to send the relevant part of the log only to
me, but reference that bug report, otherwise I'd overlook it in my spam
folder. Definitely keep the log for later use, in case I'd need more
information from it. Also note that the file as such will be fully
populated only after the factory is properly closed, due to caching,
which it might to roughly 10 seconds after you close evolution (and all
other clients connected to it, if any).
        Bye,
        Milan
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Rudolf Künzli
On Wed, 2017-07-19 at 10:33 +0200, Milan Crha wrote:

> On Tue, 2017-07-18 at 23:36 +0200, Rudolf Künzli wrote:
> > I can't repeat the problem easily...
>
> Hi,
> okay, that's a pita. Could you keep running evolution-addressbook-
> factory with EWS debugging on in the background, and when it'll
> strike
> back, then check the log for the backendError message and what
> preceded
> it, please? That would show what evolution-ews passed to the server
> and
> eventually shed a bit of light on the issues.
>
> To do that:
> a) close evolution
> b) open terminal and run in it:
>    $ EWS_DEBUG=2 /usr/libexec/evolution-addressbook-factory -w
> &>log.txt
>    Actual path can differ on your system.
> c) run evolution and use it as before
>
> The log contains all the communication between the server and the
> client, exposing all the private information down to your contacts,
> but
> the only interesting part is the one with the backendError and what
> precedes it. Maybe file a bug report in GNOME bugzilla and we can
> follow there. Feel free to send the relevant part of the log only to
> me, but reference that bug report, otherwise I'd overlook it in my
> spam
> folder. Definitely keep the log for later use, in case I'd need more
> information from it. Also note that the file as such will be fully
> populated only after the factory is properly closed, due to caching,
> which it might to roughly 10 seconds after you close evolution (and
> all
> other clients connected to it, if any).
> Bye,
> Milan
>
Hi Milan,

I did as you described above.
I had no error the whole day up to now.
The log file is empty.
Thanks

> _______________________________________________
> evolution-list mailing list
> [hidden email]
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-list
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Milan Crha
On Wed, 2017-07-19 at 13:07 +0200, Rudolf Künzli wrote:
> I had no error the whole day up to now.
> The log file is empty.

        Hi,
it should not be, as long as you opened an EWS address book in
evolution. The logging prints raw communication, thus if you'll connect
it'll be populated with some debugging information.
        Bye,
        Milan
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Rudolf Künzli
On Wed, 2017-07-19 at 13:35 +0200, Milan Crha wrote:

> On Wed, 2017-07-19 at 13:07 +0200, Rudolf Künzli wrote:
> > I had no error the whole day up to now.
> > The log file is empty.
>
> Hi,
> it should not be, as long as you opened an EWS address book in
> evolution. The logging prints raw communication, thus if you'll
> connect
> it'll be populated with some debugging information.
> Bye,
> Milan
>

Hi Milan,

It seems I didn't communicate that I not using a EWS address book.
My contacts are on Google...
Bye

> _______________________________________________
> evolution-list mailing list
> [hidden email]
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-list
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Milan Crha
        Hi,

On Wed, 2017-07-19 at 14:48 +0200, Rudolf Künzli wrote:
> It seems I didn't communicate that I not using a EWS address book.
> My contacts are on Google...

Oops, I'm so.... It's obvious from the error message, but I didn't pay
enough attention with my second mail (I did with the first, though).
I'm sorry. In that case, to run the address book factory with libgdata
debugging, do this:

b) in a terminal:
   $ export G_MESSAGES_DEBUG=all
   $ export LIBGDATA_DEBUG=255
   $ /usr/libexec/evolution-addressbook-factory -w &>log.txt

The a) and c) steps are the same as earlier.

        Bye,
        Milan
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Rudolf Künzli
On Wed, 2017-07-19 at 15:09 +0200, Milan Crha wrote:

> Hi,
>
> On Wed, 2017-07-19 at 14:48 +0200, Rudolf Künzli wrote:
> > It seems I didn't communicate that I not using a EWS address book.
> > My contacts are on Google...
>
> Oops, I'm so.... It's obvious from the error message, but I didn't
> pay
> enough attention with my second mail (I did with the first, though).
> I'm sorry. In that case, to run the address book factory with
> libgdata
> debugging, do this:
>
> b) in a terminal:
>    $ export G_MESSAGES_DEBUG=all
>    $ export LIBGDATA_DEBUG=255
>    $ /usr/libexec/evolution-addressbook-factory -w &>log.txt
>
> The a) and c) steps are the same as earlier.
>
> Bye,
> Milan

Hi Milan,

The error didn't show up for hours even I did quite a lot of
modifications, additions and deletions just to evolution busy.
I'll try again when the error show up next...
Thanks for help
> _______________________________________________
> evolution-list mailing list
> [hidden email]
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-list
>
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Milan Crha
On Wed, 2017-07-19 at 16:51 +0200, Rudolf Künzli wrote:
> The error didn't show up for hours even I did quite a lot of
> modifications, additions and deletions just to evolution busy.

        Hi,
it can also be something on the server, which got fixed meanwhile. Hard
to tell. Just keep watching it and update the thread if it strikes
again.
        Thanks and bye,
        Milan
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Rudolf Künzli
On Wed, 2017-07-19 at 16:57 +0200, Milan Crha wrote:

> On Wed, 2017-07-19 at 16:51 +0200, Rudolf Künzli wrote:
> > The error didn't show up for hours even I did quite a lot of
> > modifications, additions and deletions just to evolution busy.
>
> Hi,
> it can also be something on the server, which got fixed meanwhile.
> Hard
> to tell. Just keep watching it and update the thread if it strikes
> again.
> Thanks and bye,
> Milan
>
Okay,
I'll do so...
Thanks
> _______________________________________________
> evolution-list mailing list
> [hidden email]
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-list
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Contacts - Unable to perform a Search

Milan Crha
On Wed, 2017-07-19 at 18:12 +0200, Rudolf Künzli wrote:
> Okay,
> I'll do so...

        Hi,
I've not been able to reproduce your error, but I've got a different,
for which I added workarounds into the code with the below changes.
I've got them on simple address book refresh and right after open.
Maybe it's related to what you see. There also depends which libgdata
version you use (I've semi-ancient 0.17.7).

For 3.25.90+: https://git.gnome.org/browse/evolution-data-server/commit/?id=c2947758f2
For 3.24.5+:  https://git.gnome.org/browse/evolution-data-server/commit/?h=gnome-3-24&id=62f411191d67

        Bye,
        Milan
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Loading...