EWS account fails to create

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

EWS account fails to create

Nathan Schneider
Evolution friends,

I'm glad to join this list. I'm currently exploring whether to migrate
to Evolution from Thunderbird. A major sticking point has been that the
evolution-ews plugin does not appear to be succeeding on one of my
machines, running Evolution 3.30.5-1.1 on MX Linux 19.2. (I am not
having this problem on Ubuntu-based POP!_OS. Here's what happens:

+ I proceed with creating a new mail account with EWS and take all the
steps my employer recommends (
https://oit.colorado.edu/tutorial/office-365-evolution-configuration)

+ At the end of the process, the account-creation window closes, and no
new account is created. The Outlook login window never opens.


I have tried uninstalling and reinstalling from Debian repos, and
deleting config files.

Finally, incidentally, I'd be grateful for any recommended readings
about the Evolution roadmap (and, in particular, how it might compare
with that of Thunderbird).

Thank you in advance for any suggestions about how to proceed.

Nathan

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: EWS account fails to create

Ángel González
On 2020-06-05 at 11:37 -0600, Nathan Schneider wrote:

> Evolution friends,
>
> I'm glad to join this list. I'm currently exploring whether to migrate
> to Evolution from Thunderbird. A major sticking point has been that the
> evolution-ews plugin does not appear to be succeeding on one of my
> machines, running Evolution 3.30.5-1.1 on MX Linux 19.2. (I am not
> having this problem on Ubuntu-based POP!_OS. Here's what happens:
>
> + I proceed with creating a new mail account with EWS and take all the
> steps my employer recommends (
> https://oit.colorado.edu/tutorial/office-365-evolution-configuration)
>
> + At the end of the process, the account-creation window closes, and no
> new account is created. The Outlook login window never opens.

Hello Nathan

I understand that it fails for with 3.30.5-1.1 but you were able to make
that same account work in another system. Which version is evolution on
the working one?

It may be possible to manually copy the .config files from the working
system to the other one, but it would be even better to fix whatever
underlying problem is.


It is nice to see that evolution is supported by IT. They provide a
tutorial to do so, complete with Tenant and Application ID values.
They instruct to create the account from evolution.

I wonder if the reason the login window doesn't appear may be a package
not installed on the failing machine.
Do you see any relevant message in a console when you open evolution
from one to perform the configuration?
[Rather than opening from the UI (Step 3), opening it from a console, as
in Step 1]

It is possible to make evolution provide more messages via environment
variables, see https://wiki.gnome.org/Apps/Evolution/Debugging

Although I'm not sure what to look for there, exactly.

Kind regards

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: EWS account fails to create

Nathan Schneider
Thanks very much. Strangely, when I tried opening up Evolution today,
the Outlook login window appeared and the account was created. Very strange.

I am realizing that I'm on a pretty old version, relying on what's in
the Debian repo. I'm trying to figure out how best to upgrade—either
through the Ubuntu repo or Flatpak.

That's probably the root of my problem.

Thanks!


On 6/6/20 2:43 PM, Ángel wrote:

> On 2020-06-05 at 11:37 -0600, Nathan Schneider wrote:
>> Evolution friends,
>>
>> I'm glad to join this list. I'm currently exploring whether to migrate
>> to Evolution from Thunderbird. A major sticking point has been that the
>> evolution-ews plugin does not appear to be succeeding on one of my
>> machines, running Evolution 3.30.5-1.1 on MX Linux 19.2. (I am not
>> having this problem on Ubuntu-based POP!_OS. Here's what happens:
>>
>> + I proceed with creating a new mail account with EWS and take all the
>> steps my employer recommends (
>> https://oit.colorado.edu/tutorial/office-365-evolution-configuration)
>>
>> + At the end of the process, the account-creation window closes, and no
>> new account is created. The Outlook login window never opens.
> Hello Nathan
>
> I understand that it fails for with 3.30.5-1.1 but you were able to make
> that same account work in another system. Which version is evolution on
> the working one?
>
> It may be possible to manually copy the .config files from the working
> system to the other one, but it would be even better to fix whatever
> underlying problem is.
>
>
> It is nice to see that evolution is supported by IT. They provide a
> tutorial to do so, complete with Tenant and Application ID values.
> They instruct to create the account from evolution.
>
> I wonder if the reason the login window doesn't appear may be a package
> not installed on the failing machine.
> Do you see any relevant message in a console when you open evolution
> from one to perform the configuration?
> [Rather than opening from the UI (Step 3), opening it from a console, as
> in Step 1]
>
> It is possible to make evolution provide more messages via environment
> variables, see https://wiki.gnome.org/Apps/Evolution/Debugging
>
> Although I'm not sure what to look for there, exactly.
>
> Kind regards
>
> _______________________________________________
> evolution-list mailing list
> [hidden email]
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-list

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: EWS account fails to create

Gnome Evolution - General mailing list
On Sat, 2020-06-06 at 14:51 -0600, Nathan Schneider wrote:
> Strangely, when I tried opening up Evolution today,
> the Outlook login window appeared and the account was created. Very
> strange.

        Hi,
just a wild guess, but from what you wrote earlier and in this mail I'd
guess you installed evolution-ews, but you did not restart
evolution-data-server background processes, which is needed, with older
versions of it, to load the newly installed modules, thus it knows what
to do with the created account.

So, what you want is:
a) install evolution-ews
b) restart background processes (`evolution --force-shutdown`)
c) continue with the other steps of configuring the account.

As being said, newer evolution-data-server can handle newly installed
modules better, without the need to restart the background processes.
In any case, getting the latest stable version is a good idea, because
there had been done various fixes since 3.30.x (the current stable
series is 3.36.x).
        Bye,
        Milan

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list