Error loading attachments - version 3.32.3 (flatpak git)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Error loading attachments - version 3.32.3 (flatpak git)

Gnome Evolution - General mailing list
Hello,

I decided to switch my main computer from Windows to Linux. After comparing between Thunderbird and Evolution, I went with Evolution (really liked) and struggled a bit migrating my PST file. Now after finally configuring my work and personal accounts, when I thought everything was working correctly I tried to add an attachment to a draft and got a weird behavior:
  • If I click on the "Add Attachment..." button at the bottom nothing happens. 
  • If I drag the file that I want to attach to the draft window I get the error message: "Could not load the attachment. Error when getting information for file /home/jairolop/test.txt: no such file or directory". The file exists because I'm dragging it. In fact thinking that the problem was a long path or filename I created a simple one at HOME with the same result
Where can I find out the reason adding an attachment is failing? I'd hate to use Thunderbird instead of Evolution

Thanks a lot

Jairo Lopez

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Error loading attachments - version 3.32.3 (flatpak git)

Zan Lynx
On 7/5/2019 5:03 PM, Jairo Lopez via evolution-list wrote:

> Hello,
>
> I decided to switch my main computer from Windows to Linux. After
> comparing between Thunderbird and Evolution, I went with Evolution
> (really liked) and struggled a bit migrating my PST file. Now after
> finally configuring my work and personal accounts, when I thought
> everything was working correctly I tried to add an attachment to a draft
> and got a weird behavior:
>
>   * If I click on the "Add Attachment..." button at the bottom nothing
>     happens.
>   * If I drag the file that I want to attach to the draft window I get
>     the error message: "Could not load the attachment. Error when
>     getting information for file /home/jairolop/test.txt: no such file
>     or directory". The file exists because I'm dragging it. In fact
>     thinking that the problem was a long path or filename I created a
>     simple one at HOME with the same result
>
> Where can I find out the reason adding an attachment is failing? I'd
> hate to use Thunderbird instead of Evolution

I'm not completely familiar with either one, but if this is a Snap or
Flatpak package they run in a sandbox which restricts their access to
your files. It sounds to me as if your sandbox isn't allowing access to
your files.

See
https://askubuntu.com/questions/845644/allow-snap-apps-to-access-data-from-outside-of-container

There might also be something useful in here, although it seems more
aimed at developers:
http://docs.flatpak.org/en/latest/sandbox-permissions-reference.html


--
                 Knowledge is Power -- Power Corrupts
                         Study Hard -- Be Evil
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list