Events in CalDAV not shown anymore

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Events in CalDAV not shown anymore

Paul Kernstock
Hi,

I'm using Evolution with a CalDAV calendar on a Synology NAS and for some reason
all events in this calendar have disappeared. The point when they disappeared
was probably when I tried to accept event invitations which did not work
reliably.

I have another Evolution on another machine which shows the events just as
expected.

Trying to delete the calendar from the accounts and re-add them does not work,
the calendar seems to be empty.

I can add new events which are synced with the server and appear on other
clients. Such events also remain after restarting Evolution or the OS.

However, adding and/or deleting events from invitations from different sources
does not work. I'll get an error that the event could not be added/deleted and
that some URI could not be parsed (I can not reproduce it right now).

I'm using Evolution 3.38.1-1 on Ubuntu 20.10. Evolution's regular log does not
show any errors or warnings.

Thanks for any advice!
Paul

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Events in CalDAV not shown anymore

Gnome Evolution - General mailing list
On Wed, 2020-12-09 at 09:56 +0100, Paul Kernstock wrote:
> I'm using Evolution 3.38.1-1 on Ubuntu 20.10. Evolution's regular log
> does not show any errors or warnings.

        Hi,
try to run the calendar factory with CalDAV debugging on, which will
show you what it does in the background. The command is:

   $ CALDAV_DEBUG=1 /usr/libexec/evolution-calendar-factory -w

The actual path can differ in your distribution. After this run
Evolution, though before you start the factory delete the local cache,
in:

   ~/.cache/evolution/calendar/<calendar-UID>/

thus you'll see how it reads the content from the server. Maybe you
face this bug:
https://gitlab.gnome.org/GNOME/evolution-data-server/-/issues/260
whose fix landed for 3.38.2+.

I suppose the other Evolution instance, that with the events shown, is
3.36.x or older, right? In case it's the same version, I'd verify the
filters in the Calendar view are all off and that the calendar is
selected. I know, it's the first check people would do, I mention it
just in case. I'm sorry.

        Bye,
        Milan


_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list