Evo 3.38 composer oddities

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Evo 3.38 composer oddities

Pete Biggs

Evolution 3.38.1 on Fedora 33.

I don't know if these are Evolution issues or the new editor that is
now used in 3.38:

The back space key places the cursor in the "wrong" place when deleting
blank lines. What I mean is that if you have something like ('|'=
cursor)

      AA BB
      |
      DD EE

And press back space, I would expect the cursor to be:

      AA BB|
      DD EE

in reality it is

      AA BB
     |DD EE

I have also seen sometimes when it deletes the wrong character when
deleting lots of text (that includes NewLines) - but I can't pin it
down to anything reproducible.

Second, when replying to an HTML mail in plain text the conversion of
the HTML is not good, well, non-existent. All that seems to happen is
that the markup is removed without any attempt to mimic the layout.
Straight forward text is acceptable, but with tables it results in all
the text of the table running into one long line, no line breaks or
spaces to try and separate things, just everything pushed together.
It's also different if you "Lose Formatting" when replying compared to
switching from HTML to Plain Text within the composer (it still removes
the markup, but at least it puts in some spaces!).

Are these settings issues or bugs or "features"?

P.


_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evo 3.38 composer oddities

Gnome Evolution - General mailing list
On Thu, 2020-12-03 at 20:36 +0100, Pete Biggs wrote:
> The back space key places the cursor in the "wrong" place when
> deleting blank lines.

        Hi,
that's https://gitlab.gnome.org/GNOME/evolution/-/issues/1197 , fixed
for the current 3.38.2. I've not been able to build an update for
Fedora due to
https://bugzilla.redhat.com/show_bug.cgi?id=1899892
It sits there for approximately two weeks, which is a shame.

> Second, when replying to an HTML mail in plain text the conversion of
> the HTML is not good, well, non-existent. All that seems to happen is
> that the markup is removed without any attempt to mimic the layout.
> Straight forward text is acceptable, but with tables it results in
> all the text of the table running into one long line, no line breaks
> or spaces to try and separate things, just everything pushed
> together.

I'd not call it non-existent, when the only issue is with the tables,
or at least when the markup is removed. You are right the tables are
not covered well. It's a bug. Feel free to file it against Evolution.
I do not know how well a multiline cell of a table can be converted
into the plain text to cover layout closely.

        Bye,
        Milan

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evo 3.38 composer oddities

Pete Biggs

>
> > Second, when replying to an HTML mail in plain text the conversion of
> > the HTML is not good, well, non-existent. All that seems to happen is
> > that the markup is removed without any attempt to mimic the layout.
> > Straight forward text is acceptable, but with tables it results in
> > all the text of the table running into one long line, no line breaks
> > or spaces to try and separate things, just everything pushed
> > together.
>
> I'd not call it non-existent, when the only issue is with the tables,
> or at least when the markup is removed. You are right the tables are
> not covered well. It's a bug. Feel free to file it against Evolution.
> I do not know how well a multiline cell of a table can be converted
> into the plain text to cover layout closely.
>
Perhaps an easier approach is to use the Plain Text version in a reply
if it exists, or at least make it an option. (I understand that some
plain text versions are useless in that they just say "use html".)

Even if I switch to the plain text version, replying uses the HTML
version. Or rather the default display version is always used, not what
is currently being displayed.

How about instead of just a "Lose formatting" button you have two
buttons "Convert HTML" and "Use Plain Text version" (with the latter
greyed our if no version present).

P.

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evo 3.38 composer oddities

Gnome Evolution - General mailing list
On Fri, 2020-12-04 at 09:27 +0100, Pete Biggs wrote:
> Even if I switch to the plain text version, replying uses the HTML
> version. Or rather the default display version is always used, not
> what is currently being displayed.

        Hi,
there's a bug for it filled.

> How about instead of just a "Lose formatting" button you have two
> buttons "Convert HTML" and "Use Plain Text version" (with the latter
> greyed our if no version present).

I'm afraid it's too late, the message is gone at the time of the format
question. The question is shown also when switching the mode in the
composer, not only on open of it.
        Bye,
        Milan

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list