Evolution 3.28.1: Incorrect quoting of text emails

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Evolution 3.28.1: Incorrect quoting of text emails

Paul Smith-43
Hi all; I recently upgraded my system to Ubuntu 18.04 which provides
Evolution 3.28.1 (from Evolution 3.26).

I've noticed an annoying issue: quoting of quoted messages is broken
when replying to plain text email in HTML mode.  For example if I
receive a plain text email and it includes some quoted text like this:

------------------------
> here is a quote

and here is a response
------------------------

and I reply to this message with my composer preference set to HTML
mode, then the composer shows a response where the quoted text is at
the same quoting level as the normal text.  That is, instead of:

------------------------
> > here is a quote
>
> and here is a response
------------------------

I just get (in HTML of course):

------------------------
> here is a quote
>
> and here is a response
------------------------

And this is true no matter how many levels of quoting there are in the
original email, everything is reduced to a single level.  Converting
this message to plain text doesn't fix it.

If I'm replying to an HTML email, quoting works properly.

If I change my composer preference to disable HTML by default, then it
all works properly: the plain text reply has all the correct quoting.
If I convert the message to HTML it keeps the correct quoting.

Has anyone else run into this with Evolution 3.28?

Cheers!
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evolution 3.28.1: Incorrect quoting of text emails

Andre Klapper
On Sun, 2018-06-17 at 18:10 -0400, Paul Smith wrote:
> Has anyone else run into this with Evolution 3.28?

Which exact WebKitGTK version is used?

andre
--
Andre Klapper  |  [hidden email]
https://blogs.gnome.org/aklapper/

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evolution 3.28.1: Incorrect quoting of text emails

Paul Smith-43
On Mon, 2018-06-18 at 15:17 +0200, Andre Klapper wrote:
> On Sun, 2018-06-17 at 18:10 -0400, Paul Smith wrote:
> > Has anyone else run into this with Evolution 3.28?
>
> Which exact WebKitGTK version is used?

I'm using these versions:

$ dpkg -l \*webkit\* | grep ^i
ii  gir1.2-webkit2-4.0:amd64   2.20.2-0ubuntu0.18.04.1 amd64
ii  libwebkit2gtk-4.0-37:amd64 2.20.2-0ubuntu0.18.04.1 amd64
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evolution 3.28.1: Incorrect quoting of text emails

Paul Smith-43
In reply to this post by Paul Smith-43
Anyone have any ideas about this?  I've now had to upgrade my work
system and it's much more of a problem there, because I need to send
most of my work email in HTML mode, and it doesn't work as below...

FYI, packages:

ii  evolution                       3.28.1-2
ii  gir1.2-webkit-3.0:amd64         2.4.11-3ubuntu3
ii  gir1.2-webkit2-4.0:amd64        2.20.3-0ubuntu0.18.04.1
ii  libwebkit2gtk-4.0-37:amd64      2.20.3-0ubuntu0.18.04.1
ii  libwebkit2gtk-4.0-37-gtk2:amd64 2.20.3-0ubuntu0.18.04.1
ii  libwebkitgtk-3.0-0:amd64        2.4.11-3ubuntu3
ii  libwebkitgtk-3.0-dev:amd64      2.4.11-3ubuntu3



On Sun, 2018-06-17 at 18:10 -0400, Paul Smith wrote:

> Hi all; I recently upgraded my system to Ubuntu 18.04 which provides
> Evolution 3.28.1 (from Evolution 3.26).
>
> I've noticed an annoying issue: quoting of quoted messages is broken
> when replying to plain text email in HTML mode.  For example if I
> receive a plain text email and it includes some quoted text like
> this:
>
> ------------------------
> > here is a quote
>
> and here is a response
> ------------------------
>
> and I reply to this message with my composer preference set to HTML
> mode, then the composer shows a response where the quoted text is at
> the same quoting level as the normal text.  That is, instead of:
>
> ------------------------
> > > here is a quote
> >
> > and here is a response
>
> ------------------------
>
> I just get (in HTML of course):
>
> ------------------------
> > here is a quote
> >
> > and here is a response
>
> ------------------------
>
> And this is true no matter how many levels of quoting there are in
> the
> original email, everything is reduced to a single level.  Converting
> this message to plain text doesn't fix it.
>
> If I'm replying to an HTML email, quoting works properly.
>
> If I change my composer preference to disable HTML by default, then
> it
> all works properly: the plain text reply has all the correct
> quoting.
> If I convert the message to HTML it keeps the correct quoting.
>
> Has anyone else run into this with Evolution 3.28?
>
> Cheers!
> _______________________________________________
> evolution-list mailing list
> [hidden email]
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-list
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list