Evolution Contacts recurring error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Evolution Contacts recurring error

Gnome Evolution - General mailing list
Hello,

I'm a old school programmer just starting with Linux Mint and loving
it.  I installed Evolution and during the original install it had a few
errors but otherwise works (i.e., the Outlook.com Email and Calendar
work great!).  I've tried uninstalling and reinstalling a few times,
but it seems that error message just won;t go away, AND I cannot access
the Contacts.

The red box/error message that opens when I switch to Contacts within
Evolution reads as follows (the underlined part has been masked):

--- 8< ---

Failed to connect address book “[hidden email] : Recipient
Cache”

Unknown error

--- AND ---

Unable to open address book “Contacts”

This address book cannot be opened.  This either means that an
incorrect URI was entered, or the server is unreachable.

Detailed error message: Unable to connect to “Contacts”: No such source
for UID “_________________________”

--- 8< ---

I search quite a few hours and am at a total loss as to what to try
next.  I am so close....  I'd appreciate any help/suggestions.
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evolution Contacts recurring error

Gnome Evolution - General mailing list
I also see when selecting the Personal Contacts:

--- 8< ---

Unable to open address book “Personal”

This address book cannot be opened.  Please check that the p
ath
/home/john/.var/app/org.gnome.Evolution/data/evolution/addressbook/sys
tem-address-book exists and that permissions are set to access it.

Detailed error message: Unable to connect to “Personal”: No such source
for UID “system-address-book”

--- 8< ---

Another issue beyond my skill set/knowledge.


On Fri, 2020-05-08 at 12:21 +0000, John Balkunas via evolution-list
wrote:

> Hello,
>
> I'm a old school programmer just starting with Linux Mint and loving
> it.  I installed Evolution and during the original install it had a
> few
> errors but otherwise works (i.e., the Outlook.com Email and Calendar
> work great!).  I've tried uninstalling and reinstalling a few times,
> but it seems that error message just won;t go away, AND I cannot
> access
> the Contacts.
>
> The red box/error message that opens when I switch to Contacts within
> Evolution reads as follows (the underlined part has been masked):
>
> --- 8< ---
>
> Failed to connect address book “[hidden email] : Recipient
> Cache”
>
> Unknown error
>
> --- AND ---
>
> Unable to open address book “Contacts”
>
> This address book cannot be opened.  This either means that an
> incorrect URI was entered, or the server is unreachable.
>
> Detailed error message: Unable to connect to “Contacts”: No such
> source
> for UID “_________________________”
>
> --- 8< ---
>
> I search quite a few hours and am at a total loss as to what to try
> next.  I am so close....  I'd appreciate any help/suggestions.
> _______________________________________________
> evolution-list mailing list
> [hidden email]
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-list
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evolution Contacts recurring error

@web.de
In reply to this post by Gnome Evolution - General mailing list


---- John Balkunas via evolution-list schrieb ----

Don't forget to tell the version you are running. I guess you installed the flatpak?

>

> but it seems that error message just won;t go away, AND I cannot access

>

> the Contacts.

>

>

>

> The red box/error message that opens when I switch to Contacts within

>

> Evolution reads as follows (the underlined part has been masked):

>

>

>

> --- 8< ---

>

>

>

> Failed to connect address book “[hidden email] : Recipient

>

> Cache”

>

>

>

> Unknown error

>

>

>

> --- AND ---

>

>

>

> Unable to open address book “Contacts”

>

>

>

> This address book cannot be opened. This either means that an

>

> incorrect URI was entered, or the server is unreachable.

>

>

>

> Detailed error message: Unable to connect to “Contacts”: No such source

>

> for UID “_________________________”

>

>

>

> --- 8< ---

>

>

>

> I search quite a few hours and am at a total loss as to what to try

>

> next. I am so close.... I'd appreciate any help/suggestions.

>

I observed the same error with my version <a href="tel:3.36.2">3.36.2 (flatpak gitb091e19) and the only way to access was a complete reboot.  Closing and reopen seems to be a problem, some processes related to flatpak are not finished. I did not report this, because I was going to keep an eye on this to be sure. I hope that help. Anyway, please tell you version.

  _______________________________________________

> evolution-list mailing list

> [hidden email]

> To change your list options or unsubscribe, visit ...

> https://mail.gnome.org/mailman/listinfo/evolution-list


_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evolution Contacts recurring error

Gnome Evolution - General mailing list
I'm running Linux Mint 19.3 Cinnamon (ver. 4.4.8).

And, yes I installed it as follows:

flatpak install flathub org.gnome.Evolution
flatpak run org.gnome.Evolution
sudo apt-get update
sudo apt-get install evolution-ews

The version is reported as: 3.36.2 (by Flathub.org)

My Gnome Online Accounts is configured for Microsoft Exchange with Mail, Calendar and Contracts all checked/green; so I'd guess that's good.


From: evolution-list <[hidden email]> on behalf of S. Pfeifer <[hidden email]>
Sent: Saturday, May 9, 2020 12:26 AM
To: Evolution Mailing List <[hidden email]>
Subject: Re: [Evolution] Evolution Contacts recurring error
 


---- John Balkunas via evolution-list schrieb ----

Don't forget to tell the version you are running. I guess you installed the flatpak?

>

> but it seems that error message just won;t go away, AND I cannot access

>

> the Contacts.

>

>

>

> The red box/error message that opens when I switch to Contacts within

>

> Evolution reads as follows (the underlined part has been masked):

>

>

>

> --- 8< ---

>

>

>

> Failed to connect address book “[hidden email] : Recipient

>

> Cache”

>

>

>

> Unknown error

>

>

>

> --- AND ---

>

>

>

> Unable to open address book “Contacts”

>

>

>

> This address book cannot be opened. This either means that an

>

> incorrect URI was entered, or the server is unreachable.

>

>

>

> Detailed error message: Unable to connect to “Contacts”: No such source

>

> for UID “_________________________”

>

>

>

> --- 8< ---

>

>

>

> I search quite a few hours and am at a total loss as to what to try

>

> next. I am so close.... I'd appreciate any help/suggestions.

>

I observed the same error with my version <a href="tel:3.36.2" style="">3.36.2 (flatpak gitb091e19) and the only way to access was a complete reboot.  Closing and reopen seems to be a problem, some processes related to flatpak are not finished. I did not report this, because I was going to keep an eye on this to be sure. I hope that help. Anyway, please tell you version.

  _______________________________________________

> evolution-list mailing list

> [hidden email]

> To change your list options or unsubscribe, visit ...

> https://mail.gnome.org/mailman/listinfo/evolution-list


_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evolution Contacts recurring error

Patrick O'Callaghan
On Sat, 2020-05-09 at 11:35 +0000, John Balkunas via evolution-list
wrote:
> I'm running Linux Mint 19.3 Cinnamon (ver. 4.4.8).

Please don't top-post. It's really hard to relate what you're saying to
the message you're replying to. I had to scroll right down to the end
to understand what you're talking about. Selectively quote the relevant
part and add your comments after it. It's trivially easy to do this in
Evolution (just select the part you want to quote before replying).

poc

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Evolution Contacts recurring error

Gnome Evolution - General mailing list
In reply to this post by Gnome Evolution - General mailing list
On Sat, 2020-05-09 at 13:35 +0200, John Balkunas via evolution-list
wrote:
> flatpak install flathub org.gnome.Evolution
> flatpak run org.gnome.Evolution
> sudo apt-get update
> sudo apt-get install evolution-ews
>
> The version is reported as: 3.36.2 (by Flathub.org)

        Hi,
when you run the Flatpak version, you do not need Evolution installed
in the host system. Those two work independently. Similarly for
evolution-ews, it's part of the Flathub Flatpak already.

> My Gnome Online Accounts is configured for Microsoft Exchange with
> Mail, Calendar and Contracts all checked/green; so I'd guess that's
> good.

Right, it should be fine.

The errors you see, it looks like some error on the
evolution-source-registry side, maybe missing files. That the
evolution-addressbook-factory cannot find "system-address-book" is
suspicious, because it's the default address book, created by
evolution-data-server on demand, supposed to be always there. I do run
the same Flathub Flatpak version on a Fedora 32 box and it doesn't
suffer of these issues.

Close Evolution. Then check what evolution-related processes are
running:

   $ ps ax | grep evolution

Kill all which are from /app/ path. Then run Evolution from a command
line like this:

   $ ESR_DEBUG=1 flatpak run org.gnome.Evolution

which will start with evolution-source-registry debugging on. Maybe
it'll show something useful. You can enable EWS debugging with
EWS_DEBUG=1. Note that you might restart those /app/ processes too, to
get the debugging on. (The background processes are not closed when the
Evolution is closed.)

        Bye,
        Milan

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list