Failed to refresh folder..

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Failed to refresh folder..

Bjørn T Johansen
I am getting these all the time:

Failed to refresh folder ...
The reported error was “Authentication failed”.

I am using EWS (Local Exchange 2013 (I think)) and Evolution 3.26.1 and Arch..

Is this a known problem or? I also get errors about TLS handshake.
But all i need to to is to click X os Reconnect and everything seems to be working fine..


Regards,

BTJ

-- 
-----------------------------------------------------------------------------------------------
Bjørn T Johansen

-----------------------------------------------------------------------------------------------
Someone wrote:
"I understand that if you play a Windows CD backwards you hear strange Satanic messages"
To which someone replied:
"It's even worse than that; play it forwards and it installs Windows"
-----------------------------------------------------------------------------------------------


_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Failed to refresh folder..

Milan Crha
On Fri, 2017-10-13 at 12:06 +0200, Bjørn T Johansen wrote:
> I am using EWS (Local Exchange 2013 (I think)) and Evolution 3.26.1
> and Arch..

        Hi,
that's new to me. Though I cannot tell where the issue is, especially
due to [1], where an Arch user claimed an issue with SMTP insisting to
use STARTTLS, even when it had been set to use TLS. These two things
can be unrelated, they only share the distribution.

Evolution-ews uses libsoup, and it is supposed to set credentials for
libsoup when asked to. There had been something wrong in 2.58.0 [2],
but it is a long time ago and it is already fixed, as far as I know.

Maybe try to run evolution with EWS debugging on and check after which
request the error is reported. The most important part is
Authentication header, which contains your credentials. Either the
request (not response from the server) doesn't contain it, or it can be
somehow broken, though I doubt it. You can try to move away
/usr/bin/ntlm_auth which libsoup uses for NTLM authentications, to
check whether it'll make any difference.

I'm just blind-guessing here, though, I do not want to misguide you.
        Bye,
        Milan

[1] https://bugzilla.gnome.org/show_bug.cgi?id=787556
[2] https://bugzilla.gnome.org/show_bug.cgi?id=781590
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Failed to refresh folder..

Bjørn T Johansen
On Fri, 2017-10-13 at 12:51 +0200, Milan Crha wrote:
On Fri, 2017-10-13 at 12:06 +0200, Bjørn T Johansen wrote:
I am using EWS (Local Exchange 2013 (I think)) and Evolution 3.26.1 and Arch..
Hi, that's new to me. Though I cannot tell where the issue is, especially due to [1], where an Arch user claimed an issue with SMTP insisting to use STARTTLS, even when it had been set to use TLS. These two things can be unrelated, they only share the distribution. Evolution-ews uses libsoup, and it is supposed to set credentials for libsoup when asked to. There had been something wrong in 2.58.0 [2], but it is a long time ago and it is already fixed, as far as I know. Maybe try to run evolution with EWS debugging on and check after which request the error is reported. The most important part is Authentication header, which contains your credentials. Either the request (not response from the server) doesn't contain it, or it can be somehow broken, though I doubt it. You can try to move away /usr/bin/ntlm_auth which libsoup uses for NTLM authentications, to check whether it'll make any difference. I'm just blind-guessing here, though, I do not want to misguide you. Bye, Milan

Ok, will try some debugging when I have some time.. Thx.. :-)

BTJ

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Failed to refresh folder..

Gnome Evolution - General mailing list
In reply to this post by Bjørn T Johansen
With Evolution 3.20.5 on GNOME Version 3.20.2 on openSUSE Leap 42.3 64-
bit  also having Calendar failure error messages.

Btw errors show Yahoo Calendar, not for Google Calendar. 

Yahoo changes since December 2016 Yahoo data security issues, another update this week acknowledged widened data security issues, Yahoo may also reduce external accesses options.  


Today installed evolution-ews to see IF it helps with my Yahoo Calendar error problem.

My installing evolution-ews with zypper resolved package dependencies and installed these five: 

 evolution-ews 3.20.5-3.2   
 evolution-ews-lang 3.20.5-3.2   
 libeews-1_2-0 3.20.5-3.2    
 libewsutils0 3.20.5-3.2  
 libmspack0 0.5-7.3  


Paul W Parker


On Fri, 2017-10-13 at 12:06 +0200, Bjørn T Johansen wrote:

> I am getting these all the time:
>
> Failed to refresh folder ...
> The reported error was “Authentication failed”.
>
> I am using EWS (Local Exchange 2013 (I think)) and Evolution 3.26.1
> and Arch..
>
> Is this a known problem or? I also get errors about TLS handshake.
> But all i need to to is to click X os Reconnect and everything seems
> to be working fine..
>
>
> Regards,
>
> BTJ
>
> -- 
> _______________________________________________
> evolution-list mailing list
> [hidden email]
> To change your list options or unsubscribe, visit ...
> https://mail.gnome.org/mailman/listinfo/evolution-list
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Failed to refresh folder..

Milan Crha
On Sun, 2017-10-15 at 08:12 +1100, Paul W Parker via evolution-list
wrote:
> Today installed evolution-ews to see IF it helps with my Yahoo
> Calendar error problem.

        Hi,
as far as I know, you cannot connect to a Yahoo! calendar (which is
CalDAV) using Exchange Web Services (which is for Microsoft Exchange
servers).

I get some connection failures from the Yahoo! CalDAV calendars too,
from time to time, but they do not seem to be related to evolution-
data-server, because they go away after some time, thus I guess it can
be also some kind of maintenance on the Yahoo! server. I have no
official message for it, it's just my feeling.

There had been some general issue with Yahoo! CalDAV server passing
'\0' in the middle of headers, which seemed to be related to OAuth2
authentication method addition on their side, which had been fixed in
libsoup several months ago (quite long ago). This exhibited as a
Message Corrupt error in the UI of Evolution.
        Bye,
        Milan
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list