Hang while formatting message

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Hang while formatting message

Patrick O'Callaghan
This is in 2.3.7 and 2.3.8 at least, maybe other versions as well.

Often, when some HTML-formatted message is in the preview pane, I see
the message text and graphic placeholders, the status message at the
bottom says "Formatting message (...)" and never terminates, i.e. the
preview pane is now stuck on the message that provoked the problem. Note
that Evo itself doesn't hang: I can double-click on other messages and
see them, change folders, set preferences, send and receive mail, etc.
etc., but I cannot change the contents of the preview pane again without
forceably killing Evo and restarting.

"Cancel" does nothing.

"Quit" causes the Evo window to grey out and sit there forever. (<rant>
A Quit button should quit the application *always* -- IMHO an end user
shouldn't have to know about "evolution --force-shutdown"; I actually
have a special "KillEvo" button on my desktop since I need it so often,
even with supposedly stable versions of Evo </rant>).

In Preferences I have "Show animated images" OFF, and "Load images in
mail from contacts" ON. I've played with various combinations of these
without affecting the frequency of this bug.

poc

_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Hang while formatting message

Not Zed

Try setting the environmental variable EVOLUTION_NO_BAR=1, and see if
that stop the hangs.

Also, try disabling 'load images if sender is in addressbook', it might
be the addressbook lookup hanging - which isn't cancellable either.

I guess, file a bug, include a backtrace of all threads, and preferrably
attach example messages.

On Thu, 2005-09-01 at 19:59 -0400, Patrick O'Callaghan wrote:

> This is in 2.3.7 and 2.3.8 at least, maybe other versions as well.
>
> Often, when some HTML-formatted message is in the preview pane, I see
> the message text and graphic placeholders, the status message at the
> bottom says "Formatting message (...)" and never terminates, i.e. the
> preview pane is now stuck on the message that provoked the problem. Note
> that Evo itself doesn't hang: I can double-click on other messages and
> see them, change folders, set preferences, send and receive mail, etc.
> etc., but I cannot change the contents of the preview pane again without
> forceably killing Evo and restarting.
>
> "Cancel" does nothing.
>
> "Quit" causes the Evo window to grey out and sit there forever. (<rant>
> A Quit button should quit the application *always* -- IMHO an end user
> shouldn't have to know about "evolution --force-shutdown"; I actually
> have a special "KillEvo" button on my desktop since I need it so often,
> even with supposedly stable versions of Evo </rant>).
>
> In Preferences I have "Show animated images" OFF, and "Load images in
> mail from contacts" ON. I've played with various combinations of these
> without affecting the frequency of this bug.
>
> poc
>
> _______________________________________________
> Evolution-list mailing list
> [hidden email]
> http://mail.gnome.org/mailman/listinfo/evolution-list
--
adfa(evolution-2.4:20087): gtkhtml-WARNING **: cannot find icon:
'stock_insert-url' in gnome

_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Hang while formatting message

Tony K Lindstrom
In reply to this post by Patrick O'Callaghan
On Thu, 2005-09-01 at 19:59 -0400, Patrick O'Callaghan wrote:
> This is in 2.3.7 and 2.3.8 at least, maybe other versions as well.


>
> In Preferences I have "Show animated images" OFF, and "Load images in
> mail from contacts" ON. I've played with various combinations of these
> without affecting the frequency of this bug.
>

        I had this same problem and it definately has to do with the Load
images option. I had some nonworking address sources which caused this.
After deleting them, this problem almost disappeared, but not completely
so I have now the "Never load images from internet" setting activated.
This removed the problem completely.

        (One can always manually "Load images" if one really needs them...)



--
Tony K Lindstrom <[hidden email]>

_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Hang while formatting message

Patrick O'Callaghan
On Fri, 2005-09-02 at 14:59 +0300, Tony K Lindstrom wrote:

> On Thu, 2005-09-01 at 19:59 -0400, Patrick O'Callaghan wrote:
> > This is in 2.3.7 and 2.3.8 at least, maybe other versions as well.
>
>
> >
> > In Preferences I have "Show animated images" OFF, and "Load images in
> > mail from contacts" ON. I've played with various combinations of these
> > without affecting the frequency of this bug.
> >
>
> I had this same problem and it definately has to do with the Load
> images option. I had some nonworking address sources which caused this.
> After deleting them, this problem almost disappeared, but not completely
> so I have now the "Never load images from internet" setting activated.
> This removed the problem completely.

OK, I've set "Never load images from Internet". I'll report if it
doesn't work :-)

> (One can always manually "Load images" if one really needs them...)

And if you do, does Evo ever hang while fetching the images?

poc

_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Hang while formatting message

Patrick O'Callaghan
In reply to this post by Not Zed
I set it to "Never load images from Internet" a couple of days ago and
it hasn't hung again, touch wood.

I'll leave it at that a while longer, then maybe try the
EVOLUTION_NO_BAR=1 thing with images loading turned back on.

poc

On Fri, 2005-09-02 at 09:22 +0800, Not Zed wrote:

> Try setting the environmental variable EVOLUTION_NO_BAR=1, and see if
> that stop the hangs.
>
> Also, try disabling 'load images if sender is in addressbook', it might
> be the addressbook lookup hanging - which isn't cancellable either.
>
> I guess, file a bug, include a backtrace of all threads, and preferrably
> attach example messages.
>
> On Thu, 2005-09-01 at 19:59 -0400, Patrick O'Callaghan wrote:
> > This is in 2.3.7 and 2.3.8 at least, maybe other versions as well.
> >
> > Often, when some HTML-formatted message is in the preview pane, I see
> > the message text and graphic placeholders, the status message at the
> > bottom says "Formatting message (...)" and never terminates, i.e. the
> > preview pane is now stuck on the message that provoked the problem. Note
> > that Evo itself doesn't hang: I can double-click on other messages and
> > see them, change folders, set preferences, send and receive mail, etc.
> > etc., but I cannot change the contents of the preview pane again without
> > forceably killing Evo and restarting.
> >
> > "Cancel" does nothing.
> >
> > "Quit" causes the Evo window to grey out and sit there forever. (<rant>
> > A Quit button should quit the application *always* -- IMHO an end user
> > shouldn't have to know about "evolution --force-shutdown"; I actually
> > have a special "KillEvo" button on my desktop since I need it so often,
> > even with supposedly stable versions of Evo </rant>).
> >
> > In Preferences I have "Show animated images" OFF, and "Load images in
> > mail from contacts" ON. I've played with various combinations of these
> > without affecting the frequency of this bug.
> >
> > poc
> >
> > _______________________________________________
> > Evolution-list mailing list
> > [hidden email]
> > http://mail.gnome.org/mailman/listinfo/evolution-list

_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list