Shutdown, restart failure

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Shutdown, restart failure

Gnome Evolution - General mailing list
Evolution 3.38.2 (flatpak gite1b0310)

Distributor ID: LinuxMint
Description: Linux Mint 19.3 Tricia
Release: 19.3
Codename: tricia

Linux  5.4.0-52-generic #57~18.04.1-Ubuntu SMP 

At the present time,  if Evolution stops for any reason ( I quit out or it crashes), when it restarts it does NOT see any
configured accounts ( which is a pain as have 5 accounts currently configured).

If I manually add the accounts back in.. everything works until the next exit.  This includes configured signatures being
available to assign to accounts ( no need to recreate ).

At the point that Evolution starts up,  the console does NOT show any errors.

Give that I've been running Evolution on the same machine under the same id  for many years,  I'm wondering if I've
got some accumulated garbage that is breaking things ..  open to any other ideas as well.

Thanks. 

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Shutdown, restart failure

Gnome Evolution - General mailing list
On Mon, 2020-11-09 at 10:33 -0600, Anonymous Japhering via evolution-
list wrote:

> Evolution 3.38.2 (flatpak gite1b0310)
>
> Distributor ID: LinuxMint
> Description: Linux Mint 19.3 Tricia
> Release: 19.3
> Codename: tricia
>
> Linux  5.4.0-52-generic #57~18.04.1-Ubuntu SMP 
>
> At the present time,  if Evolution stops for any reason ( I quit out
> or it crashes), when it restarts it does NOT see any
> configured accounts ( which is a pain as have 5 accounts currently
> configured).
>
> If I manually add the accounts back in.. everything works until the
> next exit.  This includes configured signatures being
> available to assign to accounts ( no need to recreate ).
>
> At the point that Evolution starts up,  the console does NOT show any
> errors.
>
> Give that I've been running Evolution on the same machine under the
> same id  for many years,  I'm wondering if I've
> got some accumulated garbage that is breaking things ..  open to any
> other ideas as well.
>
> Thanks. 

Try running 'flatpak kill org.gnome.Evolution' before restarting
Evolution, just to make sure all of its processes are closed.
_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Shutdown, restart failure

Gnome Evolution - General mailing list
On Mon, 2020-11-09 at 16:38 +0000, Douglas Summers via evolution-list wrote:

> On Mon, 2020-11-09 at 10:33 -0600, Anonymous Japhering via evolution-
> list wrote:
> > Evolution 3.38.2 (flatpak gite1b0310)
> >
> > Distributor ID: LinuxMint
> > Description: Linux Mint 19.3 Tricia
> > Release: 19.3
> > Codename: tricia
> >
> > Linux  5.4.0-52-generic #57~18.04.1-Ubuntu SMP 
> >
> > At the present time,  if Evolution stops for any reason ( I quit out
> > or it crashes), when it restarts it does NOT see any
> > configured accounts ( which is a pain as have 5 accounts currently
> > configured).
> >
> > If I manually add the accounts back in.. everything works until the
> > next exit.  This includes configured signatures being
> > available to assign to accounts ( no need to recreate ).
> >
> > At the point that Evolution starts up,  the console does NOT show any
> > errors.
> >
> > Give that I've been running Evolution on the same machine under the
> > same id  for many years,  I'm wondering if I've
> > got some accumulated garbage that is breaking things ..  open to any
> > other ideas as well.
> >
> > Thanks. 
>
> Try running 'flatpak kill org.gnome.Evolution' before restarting
> Evolution, just to make sure all of its processes are closed.

Typically, do

flatpak ps
flatpak kill org.gnome.Evolution
flatpak run org.gnome.Evolution

With either  a pgrep -l evoltution of a   ps -aef | egrep 'evolution|flatpak"
in between.

Just as another data point, I did an Evolution backup which closes and restarts
Evolution.  Interesting thing happened, Evolution restarted with all accounts
intact.  So what is the difference between Evolution doing a restart and my
doing  File->Quit  followed by a flatpak shutown and restart ?


_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Shutdown, restart failure

Gnome Evolution - General mailing list
On Mon, 2020-11-09 at 10:49 -0600, Anonymous Japhering via evolution-
list wrote:
> Interesting thing happened, Evolution restarted with all accounts
> intact.  So what is the difference between Evolution doing a restart
> and my doing  File->Quit  followed by a flatpak shutown and restart ?

        Hi.
I guess it ran in the same sandbox. It can be your version of Flatpak
(or every Flatpak?) runs a new sandbox whenever you run an application
for it.

The accounts are provided by evolution-source-registry. I do not know
what could fail here, maybe the second evolution could not talk to the
source registry, which had been run by the first evolution. I also do
not know how those kill commands work, especially whether the Flatpak's
kill command kills only the main process or all processes in the
respective sandbox. Simply checking `ps as | grep evolution` before and
after the kill command may show whether any processes had been killed.
Those with /app/ in the path are those in the bubblewrap, from the
Flatpak.
        Bye,
        Milan

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list