Wierd debug message

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Wierd debug message

Patrick O'Callaghan
I'm trying to debug a POP connection using Evo 3.10.4 under Fedora 20
(fully updated, using KDE as the desktop). The server gives a variety of
error messgaes, either "connection reset by peer" or a timeout, or
"cannot get POP summary". Looks like it may be overloaded.

Anyway, I run "CAMEL_DEBUG=pop3 evolution >& EVO-POP-LOG" and attempt
connection with the POP server.  After one of the above error messages,
I terminate Evo and get the following in the log file:

        (evolution:18384): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
        java version "1.7.0_65"
        OpenJDK Runtime Environment (fedora-2.5.1.3.fc20-x86_64 u65-b17)
        OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)
       
That's the entire log file. The same thing happens whenever I repeat the
test.

Why I am getting a Java-related error in Evolution?

poc


_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Wierd debug message

Matthew Barnes
On Mon, 2014-08-18 at 11:54 +0100, Patrick O'Callaghan wrote:
> Why I am getting a Java-related error in Evolution?

It's the WebKit Java plugin initializing itself.

Not an error, it's just spewing its identity to stdout.

Matthew Barnes

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Wierd debug message

Patrick O'Callaghan
On Mon, 2014-08-18 at 07:49 -0400, Matthew Barnes wrote:
> On Mon, 2014-08-18 at 11:54 +0100, Patrick O'Callaghan wrote:
> > Why I am getting a Java-related error in Evolution?
>
> It's the WebKit Java plugin initializing itself.
>
> Not an error, it's just spewing its identity to stdout.

OK, then I guess my next question is why I'm getting no debug info for
the failing POP connection. I tried running again with CAMEL_DEBUG=all
and got over 120MB of logs, none of which mentioned either the server or
the pop protocol (i.e. they were all records related to my other
accounts, which are IMAP). This is after seeing the error message within
Evo.

poc

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Wierd debug message

Matthew Barnes
On Mon, 2014-08-18 at 13:16 +0100, Patrick O'Callaghan wrote:
> OK, then I guess my next question is why I'm getting no debug info for
> the failing POP connection. I tried running again with CAMEL_DEBUG=all
> and got over 120MB of logs, none of which mentioned either the server or
> the pop protocol (i.e. they were all records related to my other
> accounts, which are IMAP). This is after seeing the error message within
> Evo.

CAMEL_DEBUG=pop3 logs incoming and outgoing POP3 protocol messages, but
that first requires a connected socket.  A couple of the error messages
you mentioned imply it may not even be getting that far.

Socket connection and TLS negotiation mainly happen in the lower level
GLib library, and unfortunately -- from a quick scan of the GLib code --
I don't see any debugging facilities for that.

Matthew Barnes

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Wierd debug message

Adam Tauno Williams
In reply to this post by Patrick O'Callaghan
On Mon, 2014-08-18 at 11:54 +0100, Patrick O'Callaghan wrote:
> I'm trying to debug a POP connection using Evo 3.10.4 under Fedora 20
> (fully updated, using KDE as the desktop). The server gives a variety of
> error messgaes, either "connection reset by peer" or a timeout, or
> "cannot get POP summary". Looks like it may be overloaded.

Are you using POP [tcp/110] or POP over SSL [tcp/995]?

Is there a concrete reason you do not believe these message mean exactly
what they say?

Can you make a naked connection to your destination?

   - telnet {POP_SERVER} 110
   - telnet {POP_SERVER} 995
   - openssl s_client -crlf -connect {POP_SERVER}:110 -starttls pop3
   - openssl s_client -connect {POP_SERVER}:995

It is also possibly you are being rate-limited by your provider if this
issue is intermittent.  Or your router is junk.  Or your ISP is junk.

> Anyway, I run "CAMEL_DEBUG=pop3 evolution >& EVO-POP-LOG" and attempt
> connection with the POP server.  After one of the above error messages,
> I terminate Evo and get the following in the log file:
>         (evolution:18384): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
>         java version "1.7.0_65"
>         OpenJDK Runtime Environment (fedora-2.5.1.3.fc20-x86_64 u65-b17)
>         OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mod
> That's the entire log file. The same thing happens whenever I repeat the
> test.
> Why I am getting a Java-related error in Evolution?

It is just noise generated by a plugin.

--
Adam Tauno Williams <mailto:[hidden email]> GPG D95ED383
Systems Administrator, Python Developer, LPI / NCLA

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Wierd debug message

Patrick O'Callaghan
On Mon, 2014-08-18 at 09:51 -0400, Adam Tauno Williams wrote:

> On Mon, 2014-08-18 at 11:54 +0100, Patrick O'Callaghan wrote:
> > I'm trying to debug a POP connection using Evo 3.10.4 under Fedora
> 20
> > (fully updated, using KDE as the desktop). The server gives a
> variety of
> > error messgaes, either "connection reset by peer" or a timeout, or
> > "cannot get POP summary". Looks like it may be overloaded.
>
> Are you using POP [tcp/110] or POP over SSL [tcp/995]?
>
> Is there a concrete reason you do not believe these message mean
> exactly
> what they say?

I do believe what they say, but I was hoping for more detail in the log.
I've attempted a telnet to the server and sure enough there is a problem
at the other end, so it's not an Evo issue.

poc

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: Wierd debug message

Patrick O'Callaghan
In reply to this post by Matthew Barnes
On Mon, 2014-08-18 at 08:50 -0400, Matthew Barnes wrote:
> Socket connection and TLS negotiation mainly happen in the lower level
> GLib library, and unfortunately -- from a quick scan of the GLib code
> --
> I don't see any debugging facilities for that.

OK, thanks anyway. There appears to be a problem at the server end, not
in Evo.

poc

_______________________________________________
evolution-list mailing list
[hidden email]
To change your list options or unsubscribe, visit ...
https://mail.gnome.org/mailman/listinfo/evolution-list