working tls support?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

working tls support?

Igor Testen
Hi!

How far is the TLS support in Evolution at this stage? My SMTP server
supports TLS authentication on port 25. i.e. EHLO will return STARTTLS.

Somehow though, Evolution 2.2.3 (on gentoo) defaults to port 465 when
using the "use secure connection: always". In addition, if I manually set
the port like this: "host: mail.myhost.com:25" (domain name changed here,
but correctly set in my mail client), Evolution seems to no longer try to
connect to port 465, but authentication stil doesn't work (Check for
supported authentication types runs on until manually cancelled).

I've looked around this list and several newsgroups, but most posts
regarding TLS refer to versions of Evolution 1.x. So is this supposed to
work, or is it planned for future releases?

Thanks. Igor



_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: working tls support?

Not Zed

"use secure connection always" isn't tls, it is ssl.

use "whenever possible", it will use tls.

I tried to fix this ages ago, to say what it actually meant, but for
some unexplained reason it was seen as 'confusing to users' so was
reverted.


On Mon, 2005-09-05 at 00:13 +0200, Igor Testen wrote:

> Hi!
>
> How far is the TLS support in Evolution at this stage? My SMTP server
> supports TLS authentication on port 25. i.e. EHLO will return STARTTLS.
>
> Somehow though, Evolution 2.2.3 (on gentoo) defaults to port 465 when
> using the "use secure connection: always". In addition, if I manually set
> the port like this: "host: mail.myhost.com:25" (domain name changed here,
> but correctly set in my mail client), Evolution seems to no longer try to
> connect to port 465, but authentication stil doesn't work (Check for
> supported authentication types runs on until manually cancelled).
>
> I've looked around this list and several newsgroups, but most posts
> regarding TLS refer to versions of Evolution 1.x. So is this supposed to
> work, or is it planned for future releases?
>
> Thanks. Igor
>
>
>
> _______________________________________________
> Evolution-list mailing list
> [hidden email]
> http://mail.gnome.org/mailman/listinfo/evolution-list
--
adfa(evolution-2.4:20087): gtkhtml-WARNING **: cannot find icon:
'stock_insert-url' in gnome

_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: working tls support?

Igor Testen
Ok, I got it to work now, using the "Login" authnetication type and "use
secure connection whenever possible". The only question remaining is
that when I let evolution check which authentication types are
supported, it also tells me that CRAM-MD5 is supported (which I was
assuming anyway, since I set up qmail that way).

But when I use CRAM-MD5 as authentication I get: "Unable to authenticate
to SMTP server. Bad authentication response from server."

Any clues why? Or perhaps how I could turn the logging on for a smtp
session (from evolution)?

Regards. Igor


Not Zed wrote:

>"use secure connection always" isn't tls, it is ssl.
>
>use "whenever possible", it will use tls.
>
>I tried to fix this ages ago, to say what it actually meant, but for
>some unexplained reason it was seen as 'confusing to users' so was
>reverted.
>  
>
_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list
Reply | Threaded
Open this post in threaded view
|

Re: working tls support?

Andre Klapper
hi igor,

Am Mittwoch, den 07.09.2005, 11:44 +0200 schrieb Igor Testen:
> Or perhaps how I could turn the logging on for a smtp
> session (from evolution)?

you can set CAMEL_DEBUG=all as an environment setting before starting
evolution to get more output, see
http://gnome.org/projects/evolution/bugs.shtml for more information.
(fyi: camel is evolution's mail access library.)

cheers,
andre

--
 mailto:[hidden email] | failed!
 http://www.iomc.de



_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: working tls support?

Igor Testen
I just checked that out and the CRAM-MD5 authentication fails. I'm using
qmail with vmailmgr as authentication mechanism, so it's probably due to
these to programs not cooperating properly. I'll see what I can find
out.

On Don, 2005-09-08 at 00:15 +0200, Andre Klapper wrote:

> hi igor,
>
> Am Mittwoch, den 07.09.2005, 11:44 +0200 schrieb Igor Testen:
> > Or perhaps how I could turn the logging on for a smtp
> > session (from evolution)?
>
> you can set CAMEL_DEBUG=all as an environment setting before starting
> evolution to get more output, see
> http://gnome.org/projects/evolution/bugs.shtml for more information.
> (fyi: camel is evolution's mail access library.)
>
> cheers,
> andre
>
> _______________________________________________
> Evolution-list mailing list
> [hidden email]
> http://mail.gnome.org/mailman/listinfo/evolution-list

_______________________________________________
Evolution-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/evolution-list